summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Bremner <david@tethera.net>2019-11-02 17:33:20 -0300
committerDavid Bremner <david@tethera.net>2019-11-02 18:21:25 -0300
commit2a003f0f503b1e7a15b01664cf8217a4762d95cc (patch)
tree871c7044595b2991494756ba10d3c1e9e173c90c
parent1c8d9e172e57bad26ebb94a8cb22a959ebedb9a3 (diff)
debian upload 0.29.2-2: goodbye python2 supportdebian/0.29.2-2archive/debian/0.29.2-2
Convert to pybuild while we are at it.
-rw-r--r--debian/changelog8
-rw-r--r--debian/control14
-rw-r--r--debian/python3-notmuch.install1
-rwxr-xr-xdebian/rules13
4 files changed, 13 insertions, 23 deletions
diff --git a/debian/changelog b/debian/changelog
index 21010a1a..92b97449 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,11 @@
+notmuch (0.29.2-2) experimental; urgency=medium
+
+ * Drop python-notmuch binary package.
+ * Drop python2 build-dependency (Closes: #937161).
+ * Convert to pybuild for python bindings
+
+ -- David Bremner <bremner@debian.org> Sat, 02 Nov 2019 18:21:06 -0300
+
notmuch (0.29.2-1) unstable; urgency=medium
* New upstream bug fix release: fix file descriptor leak with gzipped
diff --git a/debian/control b/debian/control
index 31d6471c..84be657d 100644
--- a/debian/control
+++ b/debian/control
@@ -14,7 +14,6 @@ Build-Depends:
libgmime-3.0-dev (>= 3.0.3~),
libtalloc-dev,
libz-dev,
- python-all (>= 2.6.6-3~),
python3-all (>= 3.1.2-7~),
dh-python,
dh-elpa (>= 1.3),
@@ -73,19 +72,6 @@ Description: thread-based email index, search and tagging (development)
This package provides the necessary development libraries and header
files to allow you to develop new software using libnotmuch.
-Package: python-notmuch
-Architecture: all
-Section: python
-Depends: ${misc:Depends}, ${python:Depends}, libnotmuch5 (>= ${source:Version})
-Description: Python interface to the notmuch mail search and index library
- Notmuch is a system for indexing, searching, reading, and tagging
- large collections of email messages in maildir or mh format. It uses
- the Xapian library to provide fast, full-text search with a very
- convenient search syntax.
- .
- This package provides a Python interface to the notmuch
- functionality, directly interfacing with a shared notmuch library.
-
Package: python3-notmuch
Architecture: all
Section: python
diff --git a/debian/python3-notmuch.install b/debian/python3-notmuch.install
deleted file mode 100644
index 4606faae..00000000
--- a/debian/python3-notmuch.install
+++ /dev/null
@@ -1 +0,0 @@
-usr/lib/python3*
diff --git a/debian/rules b/debian/rules
index d056edb6..5a378f6e 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,9 +1,9 @@
#!/usr/bin/make -f
-python3_all = py3versions -s | xargs -n1 | xargs -t -I {} env {}
+export PYBUILD_NAME=notmuch
%:
- dh $@ --with python2,python3,elpa
+ dh $@ --with python3,elpa
override_dh_auto_configure:
BASHCMD=/bin/bash ./configure --prefix=/usr \
@@ -17,20 +17,17 @@ override_dh_auto_configure:
override_dh_auto_build:
dh_auto_build -- V=1
- dh_auto_build --sourcedirectory bindings/python
- cd bindings/python && $(python3_all) setup.py build
+ dh_auto_build --buildsystem=pybuild --sourcedirectory bindings/python
$(MAKE) -C contrib/notmuch-mutt
override_dh_auto_clean:
dh_auto_clean
- dh_auto_clean --sourcedirectory bindings/python
- cd bindings/python && $(python3_all) setup.py clean -a
+ dh_auto_clean --buildsystem=pybuild --sourcedirectory bindings/python
dh_auto_clean --sourcedirectory bindings/ruby
$(MAKE) -C contrib/notmuch-mutt clean
override_dh_auto_install:
dh_auto_install
- dh_auto_install --sourcedirectory bindings/python
- cd bindings/python && $(python3_all) setup.py install --install-layout=deb --root=$(CURDIR)/debian/tmp
+ dh_auto_install --buildsystem=pybuild --sourcedirectory bindings/python
$(MAKE) -C contrib/notmuch-mutt DESTDIR=$(CURDIR)/debian/tmp install
dh_auto_install --sourcedirectory bindings/ruby