summaryrefslogtreecommitdiffstats
path: root/tests/clamav.nix
diff options
context:
space:
mode:
authorAntoine Eiche <lewo@abesis.fr>2020-04-11 15:38:52 +0200
committerAntoine Eiche <lewo@abesis.fr>2020-04-19 10:01:57 +0200
commita53aa5ac9a080f292a45cea93e8249be2530d20b (patch)
treecb13691fb523cdd456fcbcb54b67b45ba75c11d4 /tests/clamav.nix
parent6563abc1c45de0d9e6b02cf8842005800b4e2745 (diff)
Use Niv to pin nixpkgs releases
Before using Niv, we were following channels meaning we can not reproduce CI jobs easily. In this change, we use Niv to pin these dependencies. We are also addding a tests/default.nix to be able to run these tests locally. For instance, to run the test extern.nix on the nixpkgs-19.09 release: nix-build tests/default.nix -A extern.nixpkgs_19_09 Fixes #178
Diffstat (limited to 'tests/clamav.nix')
-rw-r--r--tests/clamav.nix4
1 files changed, 3 insertions, 1 deletions
diff --git a/tests/clamav.nix b/tests/clamav.nix
index 955d1ac..62b8d7d 100644
--- a/tests/clamav.nix
+++ b/tests/clamav.nix
@@ -14,7 +14,9 @@
# You should have received a copy of the GNU General Public License
# along with this program. If not, see <http://www.gnu.org/licenses/>
-import <nixpkgs/nixos/tests/make-test.nix> {
+{ pkgs ? import <nixpkgs> {}}:
+
+import (pkgs.path + "/nixos/tests/make-test.nix") {
nodes = {
server = { config, pkgs, lib, ... }: