summaryrefslogtreecommitdiffstats
path: root/tests/build-profile.nix
diff options
context:
space:
mode:
authorJörg Thalheim <joerg@thalheim.io>2020-02-19 11:01:02 +0000
committerJörg Thalheim <joerg@thalheim.io>2020-02-23 21:29:22 +0000
commit9c952961f1f1a643b8b8e5d4efab6717afec1bbe (patch)
treee82cd82b09d80d1ce072db6664e6a8f0c27643ea /tests/build-profile.nix
parent5904e7605c5c6b26994e3b49153feaa29c35e388 (diff)
Add parallel test runner
The new test runner will evaluate all test profiles from the README.md in parallel in separate nix-build processes. Since we do not load all processes into one process, this also helps saving memory.
Diffstat (limited to 'tests/build-profile.nix')
-rw-r--r--tests/build-profile.nix19
1 files changed, 19 insertions, 0 deletions
diff --git a/tests/build-profile.nix b/tests/build-profile.nix
new file mode 100644
index 0000000..c4509d3
--- /dev/null
+++ b/tests/build-profile.nix
@@ -0,0 +1,19 @@
+{ profile }:
+
+let
+ shim = {
+ boot.loader.systemd-boot.enable = true;
+
+ fileSystems."/" = {
+ device = "/dev/disk/by-uuid/00000000-0000-0000-0000-000000000000";
+ fsType = "btrfs";
+ };
+
+ nixpkgs.config = {
+ allowBroken = true;
+ allowUnfree = true;
+ };
+ };
+in (import <nixpkgs/nixos> {
+ configuration.imports = [ profile shim ];
+}).system