summaryrefslogtreecommitdiffstats
path: root/third_party/SingleApplication-3.3.0/examples/basic/CMakeLists.txt
diff options
context:
space:
mode:
authorNicolas Werner <nicolas.werner@hotmail.de>2021-06-16 22:30:45 +0200
committerNicolas Werner <nicolas.werner@hotmail.de>2021-06-25 11:34:17 +0200
commit6a7d28d1b5564db6c45460de680282e45751d11a (patch)
tree9c1f321075969f2e63f22d90957e2e6832b42f8c /third_party/SingleApplication-3.3.0/examples/basic/CMakeLists.txt
parent12ce7686ce8a7cae411c280d30a12934b8707550 (diff)
update SingleApplication
Diffstat (limited to 'third_party/SingleApplication-3.3.0/examples/basic/CMakeLists.txt')
-rw-r--r--third_party/SingleApplication-3.3.0/examples/basic/CMakeLists.txt12
1 files changed, 12 insertions, 0 deletions
diff --git a/third_party/SingleApplication-3.3.0/examples/basic/CMakeLists.txt b/third_party/SingleApplication-3.3.0/examples/basic/CMakeLists.txt
new file mode 100644
index 00000000..c1429230
--- /dev/null
+++ b/third_party/SingleApplication-3.3.0/examples/basic/CMakeLists.txt
@@ -0,0 +1,12 @@
+cmake_minimum_required(VERSION 3.7.0)
+
+project(basic LANGUAGES CXX)
+
+# SingleApplication base class
+set(QAPPLICATION_CLASS QCoreApplication)
+add_subdirectory(../.. SingleApplication)
+
+add_executable(basic main.cpp)
+
+target_link_libraries(${PROJECT_NAME} SingleApplication::SingleApplication)
+