summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJoseph Donofry <joedonofry@gmail.com>2019-07-16 22:36:55 -0400
committerJoseph Donofry <joedonofry@gmail.com>2019-07-16 22:39:10 -0400
commit579bf234606a8974a457f244195d2b4f3594d294 (patch)
treef5289bf6d91731a0d4711ff5438c3e57d9f42d6d /CMakeLists.txt
parent377c9e4a79a078014300f35d0638b16293d924c2 (diff)
Add User Mentions Dialog
Add a RoomListItem-like button that opens a dialog containing all of the messages that would result in a highlight from the server (for example, the user is mentioned, or @room is mentioned). This is VERY rudimentary and will be completely reworked in the future to take advantage of the existing TimelineView class, instead of using a dialog like it does now. The button to show the mentions also needs work.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 4a0bf50f..09eea071 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -179,6 +179,7 @@ set(SRC_FILES
src/dialogs/LeaveRoom.cpp
src/dialogs/Logout.cpp
src/dialogs/UserProfile.cpp
+ src/dialogs/UserMentions.cpp
src/dialogs/ReadReceipts.cpp
src/dialogs/ReCaptcha.cpp
src/dialogs/RoomSettings.cpp
@@ -246,6 +247,7 @@ set(SRC_FILES
src/TypingDisplay.cpp
src/Utils.cpp
src/UserInfoWidget.cpp
+ src/UserMentionsWidget.cpp
src/UserSettingsPage.cpp
src/WelcomePage.cpp
src/main.cpp
@@ -319,6 +321,7 @@ qt5_wrap_cpp(MOC_HEADERS
src/dialogs/MemberList.h
src/dialogs/LeaveRoom.h
src/dialogs/Logout.h
+ src/dialogs/UserMentions.h
src/dialogs/UserProfile.h
src/dialogs/RawMessage.h
src/dialogs/ReadReceipts.h
@@ -385,6 +388,7 @@ qt5_wrap_cpp(MOC_HEADERS
src/TrayIcon.h
src/TypingDisplay.h
src/UserInfoWidget.h
+ src/UserMentionsWidget.h
src/UserSettingsPage.h
src/WelcomePage.h
)