summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorKonstantinos Sideris <sideris.konstantin@gmail.com>2018-09-30 14:33:54 +0300
committerKonstantinos Sideris <sideris.konstantin@gmail.com>2018-09-30 14:33:54 +0300
commit4b1b0623887c24f45257c409ce332af9b765b50d (patch)
treef299367542d90eaa869a5e5010f1ac2dbfc81136 /CMakeLists.txt
parent8f89ad15f7e47bfc48137536ad9d0d12c01da518 (diff)
Enable debug logs
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 7 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e5aa8952..45134632 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -122,6 +122,12 @@ else(NOT (CMAKE_BUILD_TYPE OR CMAKE_CONFIGURATION_TYPES))
message("Build type set to '${CMAKE_BUILD_TYPE}'")
endif(NOT (CMAKE_BUILD_TYPE OR CMAKE_CONFIGURATION_TYPES))
+if(${CMAKE_BUILD_TYPE} STREQUAL "Debug")
+ set(SPDLOG_DEBUG_ON true)
+else()
+ set(SPDLOG_DEBUG_ON false)
+endif()
+
find_program(GIT git)
if(GIT)
execute_process(
@@ -143,7 +149,7 @@ message(STATUS "Version: ${PROJECT_VERSION}")
cmake_host_system_information(RESULT BUILD_HOST QUERY HOSTNAME)
set(BUILD_USER $ENV{USER})
-configure_file(cmake/version.h config/version.h)
+configure_file(cmake/nheko.h config/nheko.h)
#
@@ -274,7 +280,6 @@ endif()
include_directories(SYSTEM ${TWEENY_INCLUDE_DIR})
include_directories(${CMAKE_SOURCE_DIR}/src)
-include_directories(${CMAKE_CURRENT_BINARY_DIR}/config)
include_directories(${Boost_INCLUDE_DIRS})
qt5_wrap_cpp(MOC_HEADERS