summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 15 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index f407d777fc..174d456787 100644
--- a/configure.ac
+++ b/configure.ac
@@ -342,7 +342,6 @@ AC_DEFINE([NETDATA_WITH_UUID], [1], [uuid usability])
OPTIONAL_UUID_CFLAGS="${UUID_CFLAGS}"
OPTIONAL_UUID_LIBS="${UUID_LIBS}"
-
# -----------------------------------------------------------------------------
# OpenSSL Cryptography and SSL/TLS Toolkit
@@ -409,6 +408,19 @@ AC_MSG_RESULT([${enable_https}])
AM_CONDITIONAL([ENABLE_HTTPS], [test "${enable_https}" = "yes"])
# -----------------------------------------------------------------------------
+# ACLK
+AC_MSG_CHECKING([if netdata ACLK should be enabled])
+if test "${ACLK}" = "yes"; then
+ enable_aclk="yes"
+ AC_DEFINE([ENABLE_ACLK], [1], [netdata ACLK])
+ CFLAGS="${CFLAGS} -DENABLE_ACLK"
+else
+ enable_aclk="no"
+fi
+AC_MSG_RESULT([${enable_aclk}])
+AM_CONDITIONAL([ENABLE_ACLK], [test "${enable_aclk}" = "yes"])
+
+# -----------------------------------------------------------------------------
# Exporting engine
AC_MSG_CHECKING([if netdata exporting engine should be used])
if test "${UV_LIBS}"; then
@@ -1146,6 +1158,7 @@ AC_SUBST([OPTIONAL_ZLIB_CFLAGS])
AC_SUBST([OPTIONAL_ZLIB_LIBS])
AC_SUBST([OPTIONAL_UUID_CFLAGS])
AC_SUBST([OPTIONAL_UUID_LIBS])
+AC_SUBST([OPTIONAL_MQTT_LIBS])
AC_SUBST([OPTIONAL_LIBCAP_CFLAGS])
AC_SUBST([OPTIONAL_LIBCAP_LIBS])
AC_SUBST([OPTIONAL_IPMIMONITORING_CFLAGS])
@@ -1284,6 +1297,7 @@ AC_CONFIG_FILES([
web/server/Makefile
web/server/static/Makefile
claim/Makefile
+ aclk/Makefile
])
AC_OUTPUT