summaryrefslogtreecommitdiffstats
path: root/contrib/debian/rules
diff options
context:
space:
mode:
authorJames Mills <prologic@shortcircuit.net.au>2020-03-06 10:27:26 +1000
committerGitHub <noreply@github.com>2020-03-06 10:27:26 +1000
commitbb884f02ff1977b3e044b5482ba652dbca29a9d6 (patch)
treeafb84ccbd581056c0696c6201947ef4e33101a78 /contrib/debian/rules
parentf6ee467617f595495ead635605e5c6a21e0b3000 (diff)
Fix missing folders in `/var/` (#8314)
This commit creates the following folders during the installation of Debian packages: - /var/log/netdata - /var/cache/netdata - /var/run/netdata During the purge of the package, these folders are removed if empty. Note that the permissions of `/var/log/netdata` allow the members of the `adm` group to read the content. Fixes #8173
Diffstat (limited to 'contrib/debian/rules')
-rwxr-xr-xcontrib/debian/rules3
1 files changed, 3 insertions, 0 deletions
diff --git a/contrib/debian/rules b/contrib/debian/rules
index 7e9d45cc29..5993712580 100755
--- a/contrib/debian/rules
+++ b/contrib/debian/rules
@@ -46,6 +46,9 @@ override_dh_install: debian/netdata.postinst
cp -rp $(TEMPTOP)/usr $(TOP)
cp -rp $(TEMPTOP)/var $(TOP)
cp -rp $(TEMPTOP)/etc $(TOP)
+ mkdir -p "$(TOP)/var/log/netdata"
+ mkdir -p "$(TOP)/var/cache/netdata"
+ mkdir -p "$(TOP)/var/run/netdata"
# Move files that local user shouldn't be editing to /usr/share/netdata
#