summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorVladimir Kobal <vlad@prokk.net>2020-02-25 21:08:41 +0200
committerGitHub <noreply@github.com>2020-02-25 21:08:41 +0200
commitd79bbbf943f72495e135eee4afc25723f886592f (patch)
tree1637e6f719f9923e92bad2e5033dce6207c2b9c1 /configure.ac
parent84421fdf0b513e9e7dc1351550b96044e92c363d (diff)
Add an AWS Kinesis connector to the exporting engine (#8145)
* Prepare files for the AWS Kinesis exporting connector * Update the documentation * Rename functions in backends * Include the connector to the Netdata buid * Add initializers and a worker * Add Kinesis specific configuration options * Add a compile time configuration check * Remove the connector data structure * Restore unit tests * Fix the compile-time configuration check * Initialize AWS SDK only once * Don't create an instance for an unknown exporting connector * Separate client and request outcome data for every instance * Fix memory cleanup, document functions * Add unit tests * Update the documentation
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 730d539d4c..7dcb221962 100644
--- a/configure.ac
+++ b/configure.ac
@@ -445,7 +445,7 @@ if test "${ACLK}" = "yes"; then
AC_MSG_CHECKING([if libmosquitto static lib is present])
if test -f "externaldeps/mosquitto/libmosquitto.a"; then
HAVE_libmosquitto_a="yes"
- else
+ else
HAVE_libmosquitto_a="no"
fi
AC_MSG_RESULT([${HAVE_libmosquitto_a}])
@@ -1311,6 +1311,7 @@ AC_CONFIG_FILES([
exporting/graphite/Makefile
exporting/json/Makefile
exporting/opentsdb/Makefile
+ exporting/aws_kinesis/Makefile
exporting/tests/Makefile
health/Makefile
health/notifications/Makefile