summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorVladimir Kobal <vlad@prokk.net>2019-10-18 15:33:05 +0300
committerGitHub <noreply@github.com>2019-10-18 15:33:05 +0300
commit8f1ee072f151a1a553959af27b7ae42cff7b311b (patch)
tree531487ae0fd9b0aa3d02a0d82844f01e8eb842d4 /configure.ac
parent2d2e3a1e1483bb8acf6d669b2e9e096af87d2eea (diff)
Fix build when CMocka isn't installed (#7129)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 3 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index c35639adc2..ea91a72991 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1142,9 +1142,10 @@ AC_ARG_ENABLE(
)
PKG_CHECK_MODULES(
- [CMOCKA], [cmocka],
+ [CMOCKA],
+ [cmocka],
[have_cmocka="yes"],
- [AC_MSG_WARN([cmocka.pc not found on the system. Unit tests disabled])]
+ [AC_MSG_NOTICE([CMocka not found on the system. Unit tests disabled])]
)
AM_CONDITIONAL([ENABLE_UNITTESTS], [test "${enable_unit_tests}" = "yes" -a "${have_cmocka}" = "yes" ])
AC_SUBST([ENABLE_UNITTESTS])