summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorAndrew Moss <1043609+amoss@users.noreply.github.com>2020-03-19 09:27:53 +0100
committerGitHub <noreply@github.com>2020-03-19 10:27:53 +0200
commit806b6fadfdba64c0f08cc7a1ecf3573aa5620dfd (patch)
tree94dfe17783daa39f5e88f7a0c7aedc1592eaadba /configure.ac
parente6f33aaf3655e663ed90df817936c0ea5f5b2437 (diff)
Fix the new cloud info in the info endpoint (#8430)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac27
1 files changed, 20 insertions, 7 deletions
diff --git a/configure.ac b/configure.ac
index ef786d2ed1..b1c9b58a30 100644
--- a/configure.ac
+++ b/configure.ac
@@ -161,14 +161,27 @@ AC_ARG_ENABLE(
,
[enable_jsonc="detect"]
)
-if test "${ACLK}" = "yes"; then
+
+# -----------------------------------------------------------------------------
+# Check if cloud is enabled and if the functionality is available
+
AC_ARG_ENABLE(
- [aclk],
- ,
- [aclk_required="${enableval}"],
- [aclk_required="detect"]
+ [cloud],
+ [AS_HELP_STRING([--disable-cloud],
+ [Disables all cloud functionality])],
+ [],
+ [enable_cloud="no"]
)
+
+AC_MSG_CHECKING([if cloud functionality should be enabled])
+if test "${enable_cloud}" != "no"; then
+ AC_DEFINE([ENABLE_CLOUD], [1], [netdata cloud functionality])
+ aclk_required="detect"
+else
+ aclk_required="no"
fi
+AC_MSG_RESULT([${enable_cloud}])
+AM_CONDITIONAL([ENABLE_CLOUD], [test "${enable_cloud}" = "yes"])
# -----------------------------------------------------------------------------
# netdata required checks
@@ -543,8 +556,7 @@ AM_CONDITIONAL([ENABLE_CAPABILITY], [test "${with_libcap}" = "yes"])
# -----------------------------------------------------------------------------
# ACLK
-#currently env var ACLK must be set to 'yes' to even consider building ACLK
-if test "${ACLK}" = "yes"; then
+if test "$enable_cloud" = "yes"; then
AC_MSG_CHECKING([if libmosquitto static lib is present])
if test -f "externaldeps/mosquitto/libmosquitto.a"; then
HAVE_libmosquitto_a="yes"
@@ -1258,6 +1270,7 @@ AC_ARG_ENABLE(
[enable_unit_tests="yes"]
)
+
PKG_CHECK_MODULES(
[CMOCKA],
[cmocka],