summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorthiagoftsm <thiagoftsm@gmail.com>2022-03-08 17:49:23 +0000
committerGitHub <noreply@github.com>2022-03-08 17:49:23 +0000
commit6123a8e1a66aa1c3d44e454f866588495b5a145e (patch)
treee6683dfd32a9d31c51c41eb1f6326f0782ad9562 /configure.ac
parent2f8f4dd6a7b0dc98563357ad4712e990a7c5c86a (diff)
CO-RE and syscalls (#12318)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index e4a00ce587..d3df33c9e4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1218,7 +1218,7 @@ if test "${build_target}" = "linux" -a "${enable_ebpf}" != "no"; then
if test "${have_libelf}" = "yes" -a \
"${have_bpf}" = "yes" -a \
"${have_libbpf}" = "yes"; then
- OPTIONAL_BPF_CFLAGS="${LIBELF_CFLAGS} -I \$(abs_top_srcdir)/externaldeps/libbpf/include"
+ OPTIONAL_BPF_CFLAGS="${LIBELF_CFLAGS} -I \$(abs_top_srcdir)/externaldeps/libbpf/include -I \$(abs_top_srcdir)/externaldeps/libbpf/include/uapi"
OPTIONAL_BPF_LIBS="\$(abs_top_srcdir)/externaldeps/libbpf/libbpf.a ${LIBELF_LIBS}"
AC_DEFINE([HAVE_LIBBPF], [1], [libbpf usability])
enable_ebpf="yes"