summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorCosta Tsaousis (ktsaou) <costa@tsaousis.gr>2017-03-04 23:05:42 +0200
committerCosta Tsaousis (ktsaou) <costa@tsaousis.gr>2017-03-04 23:05:42 +0200
commitf791c458ea6c7e5c5d67807c66341298d6e7b281 (patch)
tree37d5472b25d4b052fbdd309770f4d5a810058c99 /configure.ac
parentc45b5b81dab43dc377f5d163c2b693ab0d517bb4 (diff)
properly check features in detect mode
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 26308d8cb3..81af5a0a1e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -235,7 +235,7 @@ fi
test "${with_math}" = "yes" -a -z "${MATH_LIBS}" && AC_MSG_ERROR([math required but not found])
AC_MSG_CHECKING([if libm should be used])
-if test "${with_math}" != "no"; then
+if test "${with_math}" != "no" -a ! -z "${MATH_LIBS}"; then
with_math="yes"
AC_DEFINE([STORAGE_WITH_MATH], [1], [math usability])
OPTIONAL_MATH_CFLAGS="${MATH_CFLAGS}"
@@ -258,7 +258,7 @@ PKG_CHECK_MODULES(
test "${with_zlib}" = "yes" -a "${have_zlib}" != "yes" && AC_MSG_ERROR([zlib required but not found. Try installing 'zlib1g-dev' or 'zlib-devel'.])
AC_MSG_CHECKING([if zlib should be used])
-if test "${with_zlib}" != "no"; then
+if test "${with_zlib}" != "no" -a "${have_zlib}" = "yes"; then
with_zlib="yes"
AC_DEFINE([NETDATA_WITH_ZLIB], [1], [zlib usability])
OPTIONAL_ZLIB_CLFAGS="${ZLIB_CFLAGS}"
@@ -302,7 +302,7 @@ PKG_CHECK_MODULES(
test "${with_libcap}" = "yes" -a "${have_libcap}" != "yes" && AC_MSG_ERROR([libcap required but not found.])
AC_MSG_CHECKING([if libcap should be used])
-if test "${with_libcap}" != "no"; then
+if test "${with_libcap}" != "no" -a "${have_libcap}" = "yes"; then
with_libcap="yes"
AC_DEFINE([HAVE_CAPABILITY], [1], [libcap usability])
OPTIONAL_LIBCAP_CLFAGS="${LIBCAP_CFLAGS}"