summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorPavlos Emm. Katsoulakis <paul@netdata.rocks>2019-06-28 08:27:57 +0200
committerPavlos Emm. Katsoulakis <paul@netdata.rocks>2019-06-28 08:27:57 +0200
commit171d8f5d01f17dddbd531139b86e1a1c96f95b0d (patch)
tree7b2f049259656e4c14c3d7e23a639964ebb2e07b /configure.ac
parent5d5266dc1a863d877d91cab232b6369091a198ee (diff)
Revert "Easily disable alarms, by persisting the silencers configuration (#6274)"
This reverts commit 60a73e90de2aa1c2eaae2ebbc45dd1fb96034df2. Emergency rollback of potential culprit as per issue #6356 Will be re-merging the change after investigation
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac39
1 files changed, 0 insertions, 39 deletions
diff --git a/configure.ac b/configure.ac
index fcf1931fcc..1b021255a5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -143,12 +143,6 @@ AC_ARG_ENABLE(
[enable_https="detect"]
)
AC_ARG_ENABLE(
- [jsonc],
- [AS_HELP_STRING([--enable-jsonc], [Enable JSON-C support @<:@default autodetect@:>@])],
- ,
- [enable_jsonc="detect"]
-)
-AC_ARG_ENABLE(
[dbengine],
[AS_HELP_STRING([--disable-dbengine], [disable netdata dbengine @<:@default autodetect@:>@])],
,
@@ -354,20 +348,6 @@ OPTIONAL_SSL_CFLAGS="${SSL_CFLAGS}"
OPTIONAL_SSL_LIBS="${SSL_LIBS}"
# -----------------------------------------------------------------------------
-# JSON-C library
-
-PKG_CHECK_MODULES([JSON],[json-c],AC_CHECK_LIB(
- [json-c],
- [json_object_get_type],
- [JSONC_LIBS="-ljson-c"]),AC_CHECK_LIB(
- [json],
- [json_object_get_type],
- [JSONC_LIBS="-ljson"])
- )
-
-OPTIONAL_JSONC_LIBS="${JSONC_LIBS}"
-
-# -----------------------------------------------------------------------------
# DB engine and HTTPS
test "${enable_dbengine}" = "yes" -a -z "${UV_LIBS}" && \
AC_MSG_ERROR([libuv required but not found. Try installing 'libuv1-dev' or 'libuv-devel'.])
@@ -402,22 +382,6 @@ AC_MSG_RESULT([${enable_https}])
AM_CONDITIONAL([ENABLE_HTTPS], [test "${enable_https}" = "yes"])
# -----------------------------------------------------------------------------
-# JSON-C
-test "${enable_jsonc}" = "yes" -a -z "${JSONC_LIBS}" && \
- AC_MSG_ERROR([JSON-C required but not found. Try installing 'libjson-c-dev' or 'json-c'.])
-
-AC_MSG_CHECKING([if json-c should be used])
-if test "${enable_jsonc}" != "no" -a "${JSONC_LIBS}"; then
- enable_jsonc="yes"
- AC_DEFINE([ENABLE_JSONC], [1], [netdata json-c usability])
-else
- enable_jsonc="no"
-fi
-AC_MSG_RESULT([${enable_jsonc}])
-AM_CONDITIONAL([ENABLE_JSONC], [test "${enable_jsonc}" = "yes"])
-
-
-# -----------------------------------------------------------------------------
# compiler options
AC_ARG_VAR([SSE_CANDIDATE], [C compiler flags for SSE])
@@ -1011,7 +975,6 @@ AC_SUBST([OPTIONAL_UV_LIBS])
AC_SUBST([OPTIONAL_LZ4_LIBS])
AC_SUBST([OPTIONAL_JUDY_LIBS])
AC_SUBST([OPTIONAL_SSL_LIBS])
-AC_SUBST([OPTIONAL_JSONC_LIBS])
AC_SUBST([OPTIONAL_NFACCT_CFLAGS])
AC_SUBST([OPTIONAL_NFACCT_LIBS])
AC_SUBST([OPTIONAL_ZLIB_CFLAGS])
@@ -1078,8 +1041,6 @@ AC_CONFIG_FILES([
libnetdata/config/Makefile
libnetdata/dictionary/Makefile
libnetdata/eval/Makefile
- libnetdata/json/Makefile
- libnetdata/health/Makefile
libnetdata/locks/Makefile
libnetdata/log/Makefile
libnetdata/popen/Makefile