summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorVladimir Kobal <vlad@prokk.net>2020-04-06 09:26:25 +0300
committerGitHub <noreply@github.com>2020-04-06 09:26:25 +0300
commitebbce7c7773a886d222dbaa60d098b6c25150f69 (patch)
tree03848706164fba421a72c9bedf25f421ffdafa25 /configure.ac
parent50209f1971280324b0e692ac01bf45e809874856 (diff)
Prometheus web api connector (#8540)
* Fix the Prometheus web API code in the exporting engine * Rename connector types * Remove the conditional compilation of the exporting engine * Use labels instead of tags * Fix the exporter configuration * Document functions * Add unit tests
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 0 insertions, 14 deletions
diff --git a/configure.ac b/configure.ac
index 7347dac1d5..463a70cbbc 100644
--- a/configure.ac
+++ b/configure.ac
@@ -434,20 +434,6 @@ AC_MSG_RESULT([${enable_https}])
AM_CONDITIONAL([ENABLE_HTTPS], [test "${enable_https}" = "yes"])
# -----------------------------------------------------------------------------
-# Exporting engine
-AC_MSG_CHECKING([if netdata exporting engine should be used])
-if test "${UV_LIBS}"; then
- enable_exporting_engine="yes"
- AC_DEFINE([ENABLE_EXPORTING], [1], [netdata exporting engine usability])
- OPTIONAL_UV_CFLAGS="${UV_CFLAGS}"
- OPTIONAL_UV_LIBS="${UV_LIBS}"
-else
- enable_exporting_engine="no"
-fi
-AC_MSG_RESULT([${enable_exporting_engine}])
-AM_CONDITIONAL([ENABLE_EXPORTING], [test "${enable_exporting_engine}" = "yes"])
-
-# -----------------------------------------------------------------------------
# JSON-C
test "${enable_jsonc}" = "yes" -a -z "${JSONC_LIBS}" && \
AC_MSG_ERROR([JSON-C required but not found. Try installing 'libjson-c-dev' or 'json-c'.])