summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMarkos Fountoulakis <44345837+mfundul@users.noreply.github.com>2020-06-20 22:13:22 +0300
committerGitHub <noreply@github.com>2020-06-20 22:13:22 +0300
commit431b1c85698feb33aee2e8cf972dcdf6fb26ba46 (patch)
treed4c81546538649529e7a303dbaf2134cde2d9996 /configure.ac
parentae944cd492ceeec4a466c2e976fbeea0fb18bc66 (diff)
Add libuv thread names support to FATAL log level (#9382)
* Add support for the fatal() family of calls to detect non-netdata thread names from the OS
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 4bebda621d..1cba7bdd49 100644
--- a/configure.ac
+++ b/configure.ac
@@ -265,6 +265,12 @@ LIBS="${PTHREAD_LIBS} ${LIBS}"
CFLAGS="${CFLAGS} ${PTHREAD_CFLAGS}"
CC="${PTHREAD_CC}"
+AC_CHECK_LIB(
+[pthread],
+[pthread_getname_np],
+[AC_DEFINE([HAVE_PTHREAD_GETNAME_NP], [1], [Is set if pthread_getname_np is available])]
+)
+
# -----------------------------------------------------------------------------
# libm