summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorTimo <6674623+underhood@users.noreply.github.com>2020-03-26 17:48:58 +0100
committerGitHub <noreply@github.com>2020-03-26 17:48:58 +0100
commit204528e618274918d55b00d96eafe843a2006672 (patch)
tree57e872844e1cffada56d87244a6b11ecc6b1729a /configure.ac
parent78c3f35af87b57a2988f3878302284a9de37977e (diff)
Report Why ACLK build failed (#8429)
Reports ACLK build failures to GA (if the user didn't opt-out)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index b1c9b58a30..a68dde8ae6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -562,6 +562,7 @@ if test "$enable_cloud" = "yes"; then
HAVE_libmosquitto_a="yes"
else
HAVE_libmosquitto_a="no"
+ AC_DEFINE([ACLK_NO_LIBMOSQ], [1], [Libmosquitto.a was not found during build.])
fi
AC_MSG_RESULT([${HAVE_libmosquitto_a}])
@@ -571,6 +572,7 @@ if test "$enable_cloud" = "yes"; then
HAVE_libwebsockets_a="yes"
else
HAVE_libwebsockets_a="no"
+ AC_DEFINE([ACLK_NO_LWS], [1], [libwebsockets.a was not found during build.])
fi
AC_MSG_RESULT([${HAVE_libwebsockets_a}])