summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorVladimir Kobal <vlad@prokk.net>2020-08-31 16:01:59 +0300
committerGitHub <noreply@github.com>2020-08-31 16:01:59 +0300
commitc857c880f31a89b7857bf01f1f48227c41bf8a93 (patch)
treec67b81b9e3aaceea1cd7b817910814e9761c0f6d /configure.ac
parent8ae0a356ffe07418334be51907f2886d64b1255b (diff)
Don't install eBPF plugin components when they shouldn't be installed (#9844)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index b3ff4ba785..190f3cd50a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -167,6 +167,12 @@ AC_ARG_ENABLE(
,
[enable_jsonc="detect"]
)
+AC_ARG_ENABLE(
+ [ebpf],
+ [AS_HELP_STRING([--disable-ebpf], [Disable eBPF support @<:@default autodetect@:>@])],
+ ,
+ [enable_ebpf="detect"]
+)
# -----------------------------------------------------------------------------
# Check if cloud is enabled and if the functionality is available
@@ -968,6 +974,7 @@ AC_CHECK_FILE(
AC_MSG_CHECKING([if ebpf.plugin should be enabled])
if test "${build_target}" = "linux" -a \
+ "${enable_ebpf}" != "no" -a \
"${have_libelf}" = "yes" -a \
"${have_bpf}" = "yes" -a \
"${have_libbpf}" = "yes"; then