summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorthiagoftsm <thiagoftsm@gmail.com>2023-05-15 16:06:26 +0000
committerGitHub <noreply@github.com>2023-05-15 19:06:26 +0300
commit588096c6b682ec467d85656abab65d77f74e5755 (patch)
tree64d88be9c0ec23c5d79370cc1bed826e19a2b51a /configure.ac
parentbdc40c318a761f5e05e3544b72c4aa3384484e44 (diff)
Debugfs collector (#15017)
Co-authored-by: Fotis Voutsas <fotis@netdata.cloud> Co-authored-by: Austin S. Hemmelgarn <ahferroin7@gmail.com> Co-authored-by: ilyam8 <ilya@netdata.cloud>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 16 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 6b3985a3a0..e89798c908 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1294,6 +1294,21 @@ fi
# -----------------------------------------------------------------------------
+# debugfs.plugin
+
+if test "${build_target}" = "linux"; then
+ AC_DEFINE([ENABLE_DEBUGFS_PLUGIN], [1], [debugfs.plugin])
+ enable_plugin_debugfs="yes"
+else
+ enable_plugin_debugfs="no"
+fi
+
+AC_MSG_CHECKING([if debugfs.plugin should be enabled])
+AC_MSG_RESULT([${enable_plugin_debugfs}])
+AM_CONDITIONAL([ENABLE_PLUGIN_DEBUGFS], [test "${enable_plugin_debugfs}" = "yes"])
+
+
+# -----------------------------------------------------------------------------
# ebpf.plugin
if test "${build_target}" = "linux" -a "${enable_ebpf}" != "no"; then
@@ -1808,6 +1823,7 @@ AC_CONFIG_FILES([
collectors/apps.plugin/Makefile
collectors/cgroups.plugin/Makefile
collectors/charts.d.plugin/Makefile
+ collectors/debugfs.plugin/Makefile
collectors/diskspace.plugin/Makefile
collectors/timex.plugin/Makefile
collectors/ioping.plugin/Makefile