summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorTimotej S <6674623+underhood@users.noreply.github.com>2022-12-14 10:31:34 +0700
committerGitHub <noreply@github.com>2022-12-14 10:31:34 +0700
commit5847aeadcce2ea03dba23fc7baabcd4d04dfecb9 (patch)
tree284f50fc9390cc494c3480f829797717f4475972 /configure.ac
parentac52d5de53804d336f2ab63d19aaa7c6a15ce028 (diff)
expose ACLK SSL KeyLog interface for developers (#14109)
* add possibility to decypt trafic for developers for debugging purposes * requires netdata to be explicitly built with this feature enabled
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 5a39092414..53e673c2a6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -213,6 +213,12 @@ AC_ARG_ENABLE(
[enable_ml_tests="yes"],
[enable_ml_tests="no"]
)
+AC_ARG_ENABLE(
+ [aclk_ssl_debug],
+ [AS_HELP_STRING([--enable-aclk-ssl-debug], [Enables possibility for SSL key logging @<:@default no@:>@])],
+ [aclk_ssl_debug="yes"],
+ [aclk_ssl_debug="no"]
+)
# -----------------------------------------------------------------------------
# Enforce building with C99, bail early if we can't.
@@ -713,6 +719,11 @@ if test "${with_bundled_protobuf}" != "no"; then
fi
fi
+AM_CONDITIONAL([MQTT_WSS_DEBUG], [test "${aclk_ssl_debug}" = "yes"])
+if test "${aclk_ssl_debug}" = "yes"; then
+ AC_DEFINE([MQTT_WSS_DEBUG], [1], [ACLK SSL allow debugging])
+fi
+
if test "${with_bundled_protobuf}" != "yes"; then
PKG_CHECK_MODULES(
[PROTOBUF],