summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorAustin S. Hemmelgarn <austin@netdata.cloud>2020-07-30 07:09:59 -0400
committerGitHub <noreply@github.com>2020-07-30 07:09:59 -0400
commit8a105bad8188b7581c92811c069676d3110f130b (patch)
tree0c6358e5c8c5f7b25436760b298b0de3107f4a1f /configure.ac
parentfdbc559ff9c317ce6cf42a72ea466a2b47211971 (diff)
Added eBPF collector support to DEB and RPM packages. (#9628)
* Add DEB/RPM package build tests to Travis. * Add working support for bundling eBPF in binary packages. * Show stdout and stderr from commands run in LXC. * Add proper bundling code for libbpf. * Use AC_CHECK_FILE for libbpf.a external dep. This way it gets properly logged in both configure output and the configure log.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 7 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 6268734922..b3ff4ba785 100644
--- a/configure.ac
+++ b/configure.ac
@@ -960,11 +960,17 @@ AC_CHECK_TYPE(
[#include <linux/bpf.h>]
)
+AC_CHECK_FILE(
+ externaldeps/libbpf/libbpf.a,
+ [have_libbpf=yes],
+ [have_libbpf=no]
+)
+
AC_MSG_CHECKING([if ebpf.plugin should be enabled])
if test "${build_target}" = "linux" -a \
"${have_libelf}" = "yes" -a \
"${have_bpf}" = "yes" -a \
- -f externaldeps/libbpf/libbpf.a; then
+ "${have_libbpf}" = "yes"; then
OPTIONAL_BPF_CFLAGS="${LIBELF_CFLAGS} -I externaldeps/libbpf/include"
OPTIONAL_BPF_LIBS="externaldeps/libbpf/libbpf.a ${LIBELF_LIBS}"
AC_DEFINE([HAVE_LIBBPF], [1], [libbpf usability])