summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorCosta Tsaousis <costa@tsaousis.gr>2018-10-23 00:38:04 +0300
committerGitHub <noreply@github.com>2018-10-23 00:38:04 +0300
commit09e89e937af3bcc5948b92c722c8da93970bd987 (patch)
tree59045c88e9d636e3ffcebca4af8b3183b1d86f97 /configure.ac
parentc09afb49a964e58620e08961869a0cfbea72691c (diff)
modularize the query api (#4443)
* modularized exporters * modularized API data queries * optimized queries * modularized API data reduction methods * modularized api queries * added new directories in makefiles * added median db query * moved all RRDR_GROUPING related to query.h * added stddev query * operational median and stddev * working simple exponential smoothing * too complex to do it right * fixed ses * fixed ses * rewrote query engine * fix double-exponential-smoothing * cleanup * fixed bug identified by @vlvkobal at rrdset_first_slot() * enable freeipmi on systems with libipmimonitoring; #4440
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 12 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index a75f2e1f26..e0313dcd91 100644
--- a/configure.ac
+++ b/configure.ac
@@ -604,6 +604,18 @@ AC_CONFIG_FILES([
web/Makefile
web/api/Makefile
web/api/badges/Makefile
+ web/api/exporters/Makefile
+ web/api/exporters/shell/Makefile
+ web/api/exporters/prometheus/Makefile
+ web/api/queries/Makefile
+ web/api/queries/average/Makefile
+ web/api/queries/incremental_sum/Makefile
+ web/api/queries/max/Makefile
+ web/api/queries/median/Makefile
+ web/api/queries/min/Makefile
+ web/api/queries/ses/Makefile
+ web/api/queries/stddev/Makefile
+ web/api/queries/sum/Makefile
web/gui/Makefile
web/server/Makefile
web/server/single/Makefile