summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorAustin S. Hemmelgarn <austin@netdata.cloud>2020-09-24 06:54:58 -0400
committerGitHub <noreply@github.com>2020-09-24 06:54:58 -0400
commitf47b430780b812b37b5bba241982c4741dc934b7 (patch)
treea5f6965dfa5a043a8a037dc326203febf06b31b2 /configure.ac
parent80676423617d2587632eb69c9ea5a0ef0cb49d0c (diff)
Added more stringent check for C99 support in configure script. (#9982)
This will help ensure that people who are building on a compiler that does not support C99 get a more useful message about needing C99 and also avoid wasting time getting into the build itself.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 7d9938f8b3..57f6c0b1cb 100644
--- a/configure.ac
+++ b/configure.ac
@@ -174,6 +174,10 @@ AC_ARG_ENABLE(
)
# -----------------------------------------------------------------------------
+# Enforce building with C99, bail early if we can't.
+test "${ac_cv_prog_cc_c99}" = "no" && AC_MSG_ERROR([Netdata rquires a compiler that supports C99 to build])
+
+# -----------------------------------------------------------------------------
# Check if cloud is enabled and if the functionality is available
AC_ARG_ENABLE(