summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorvkalintiris <vasilis@netdata.cloud>2022-05-02 17:59:40 +0300
committerGitHub <noreply@github.com>2022-05-02 17:59:40 +0300
commitb6d2a3662dfb683e9e95203ef3b21f8e31238b06 (patch)
treeedfb6db2fa5cc932b36834e6b41017bc8182d8d8 /configure.ac
parentdb9b85a9cb9eac7b55a4145207ccc407e4064f4c (diff)
Make atomics a hard-dep. (#12730)
They are used extensively throughout our code base, and not having support for them does not generate a thread-safe agent.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 0 insertions, 11 deletions
diff --git a/configure.ac b/configure.ac
index c488f06f54..914a871a8b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -260,7 +260,6 @@ AC_TYPE_UINT64_T
AC_C_INLINE
AC_FUNC_STRERROR_R
AC_C__GENERIC
-AC_C___ATOMIC
# AC_C_STMT_EXPR
AC_CANONICAL_HOST
AC_HEADER_MAJOR
@@ -1546,14 +1545,6 @@ AC_MSG_RESULT([${enable_lto}])
# -----------------------------------------------------------------------------
-if test "${enable_exporting_kinesis}" = "yes" -o \
- "${enable_exporting_pubsub}" = "yes" -o \
- "${enable_exporting_prometheus_remote_write}" = "yes" -o \
- "${new_cloud_protocol}" = "yes" -o \
- "${build_ml}" = "yes"; then
- enable_cxx_linker="yes"
-fi
-
# Try to unconditionally link with -latomic. If the compiler can satisfy
# all the atomic ops with builtins then, the library will be left unused.
# Otherwise, some ops will be covered by the compiler's intrinsics and some
@@ -1583,8 +1574,6 @@ AC_SUBST([OPTIONAL_ATOMIC_LIBS])
AC_LANG_POP([C++])
-AM_CONDITIONAL([ENABLE_CXX_LINKER], [test "${enable_cxx_linker}" = "yes"])
-
AC_DEFINE_UNQUOTED([NETDATA_USER], ["${with_user}"], [use this user to drop privileged])
varlibdir="${localstatedir}/lib/netdata"