summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorAustin S. Hemmelgarn <austin@netdata.cloud>2021-11-08 07:49:18 -0500
committerGitHub <noreply@github.com>2021-11-08 07:49:18 -0500
commita67c830243a12ac7ce9d46aa5f5aef6c2374ec39 (patch)
treed6bdcd4699baf7a6c31a163a45b53eb9f1ca1b95 /configure.ac
parent989c68cac8ae800e369ceac1abc825846982ff34 (diff)
Add protobuf to `-W buildinfo` output. (#11634)
* Re-sort buildinfo macros. * Add protobuf to buildinfo output. * Add info about whether protobuf is from the system or bundled. * Reorganize checks to be slightly saner. * Move declaration to the correct place.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 4b42d8481b..f9d051548d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -700,6 +700,7 @@ AS_IF(
)
else
AC_MSG_NOTICE([using bundled protobuf])
+ AC_DEFINE([BUNDLED_PROTOBUF], [1], [Using a bundled copy of protobuf])
PROTOC="\$(abs_top_srcdir)/externaldeps/protobuf/src/protoc"
PROTOBUF_CFLAGS="-I \$(abs_top_srcdir)/externaldeps/protobuf/src"
PROTOBUF_LIBS="\$(abs_top_srcdir)/externaldeps/protobuf/src/.libs/libprotobuf.a"
@@ -714,6 +715,10 @@ AS_IF(
[have_CXX_compiler=yes]
)
+if test "${have_libprotobuf}" == "yes" && test "${have_CXX_compiler}" == "yes"; then
+ AC_DEFINE([HAVE_PROTOBUF], [1], [Protobuf is available])
+fi
+
AC_MSG_CHECKING([if Cloud functionality should be enabled])
AC_MSG_RESULT([${enable_cloud}])
if test "$aclk_ng" = "no"; then