summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorCosta Tsaousis (ktsaou) <costa@tsaousis.gr>2017-01-07 19:54:48 +0200
committerCosta Tsaousis (ktsaou) <costa@tsaousis.gr>2017-01-07 19:54:48 +0200
commitcea19eee0c125d817858d185c7b5e4e6f4235f08 (patch)
treec8dc0091b8a412df9c1f77a914f10cdcd921258c /configure.ac
parent6e72b3fe8660168b3edab8e2fad8771c1918c3b0 (diff)
use autoconf for checking gcc function attributes
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index d2745f62fc..872427944e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -24,6 +24,12 @@ PACKAGE_RPM_VERSION="VERSION_NUMBER"
AC_SUBST([PACKAGE_RPM_VERSION])
AC_SUBST([PACKAGE_RPM_RELEASE])
+AX_GCC_FUNC_ATTRIBUTE(returns_nonnull)
+AX_GCC_FUNC_ATTRIBUTE(malloc)
+AX_GCC_FUNC_ATTRIBUTE(noreturn)
+AX_GCC_FUNC_ATTRIBUTE(format)
+AX_GCC_FUNC_ATTRIBUTE(warn_unused_result)
+
AC_CONFIG_AUX_DIR([.])
AC_CONFIG_HEADERS([config.h])
AC_CONFIG_MACRO_DIR([m4])