summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorAustin S. Hemmelgarn <austin@netdata.cloud>2020-09-01 08:48:30 -0400
committerGitHub <noreply@github.com>2020-09-01 08:48:30 -0400
commit6887d73545db62bcda8c7cf829389ac6f19d5131 (patch)
tree400e60e803a2a9390f158021babfc6a7ca213747 /Makefile.am
parentd8e96eba6b241905e7ec84e75223a290acc67149 (diff)
Added code to bundle libJudy on systems which do not provide a usable copy of it. (#9776)
* Add installer code to bundle libJudy. * Update libJudy build to work on more systems. * Added libtool to deps. * First part of configure changes - detection of library * Configure change part two: integrating flags into the build I've tested the build works and that the symbols end up correct in the compiled binary, but I have not tested that dbengine is working properly after the changes. * Add required configure options for bundling libJudy. * Bail early if a libJudy build step fails. * Added messges for specific reasons libJudy is being built. * Fix bail condition for bundling failures. We don't care about whether the cloud is required or not, just whether the user asked for a local build of libJudy or not. * Fix logic for deciding when to bundle libJudy. * Fix judy build to clean up properly if it fails. Co-authored-by: Andrew Moss <1043609+amoss@users.noreply.github.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 4fdb400ba3..c64fa6a2cc 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -66,6 +66,8 @@ dist_noinst_DATA = \
packaging/go.d.checksums \
packaging/jsonc.version \
packaging/jsonc.checksums \
+ packaging/judy.version \
+ packaging/judy.checksums \
packaging/libwebsockets.version \
packaging/libwebsockets.checksums \
packaging/mosquitto.version \