summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorvkalintiris <vasilis@netdata.cloud>2022-01-19 08:54:37 +0200
committerGitHub <noreply@github.com>2022-01-19 08:54:37 +0200
commit37082fcbc150619b54b2a64c3621afc617607adc (patch)
treec0a5559cd3c5f1abcda0c099de993273bcebaff5 /Makefile.am
parentcc119e9e878959f155d38630c6d8e504d213383e (diff)
Compute platform-specific list of static_threads at runtime. (#11955)
Compute array of static threads at runtime.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am13
1 files changed, 5 insertions, 8 deletions
diff --git a/Makefile.am b/Makefile.am
index 7c699ce7c1..d64361711a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -201,7 +201,6 @@ APPS_PLUGIN_FILES = \
CHECKS_PLUGIN_FILES = \
collectors/checks.plugin/plugin_checks.c \
- collectors/checks.plugin/plugin_checks.h \
$(NULL)
FREEBSD_PLUGIN_FILES = \
@@ -271,7 +270,6 @@ endif
IDLEJITTER_PLUGIN_FILES = \
collectors/idlejitter.plugin/plugin_idlejitter.c \
- collectors/idlejitter.plugin/plugin_idlejitter.h \
$(NULL)
CGROUPS_PLUGIN_FILES = \
@@ -285,12 +283,10 @@ CGROUP_NETWORK_FILES = \
$(NULL)
DISKSPACE_PLUGIN_FILES = \
- collectors/diskspace.plugin/plugin_diskspace.h \
collectors/diskspace.plugin/plugin_diskspace.c \
$(NULL)
TIMEX_PLUGIN_FILES = \
- collectors/timex.plugin/plugin_timex.h \
collectors/timex.plugin/plugin_timex.c \
$(NULL)
@@ -413,7 +409,6 @@ PROC_PLUGIN_FILES = \
TC_PLUGIN_FILES = \
collectors/tc.plugin/plugin_tc.c \
- collectors/tc.plugin/plugin_tc.h \
$(NULL)
MACOS_PLUGIN_FILES = \
@@ -571,7 +566,6 @@ REGISTRY_PLUGIN_FILES = \
STATSD_PLUGIN_FILES = \
collectors/statsd.plugin/statsd.c \
- collectors/statsd.plugin/statsd.h \
$(NULL)
WEB_PLUGIN_FILES = \
@@ -869,7 +863,8 @@ DAEMON_FILES = \
daemon/signals.c \
daemon/signals.h \
daemon/service.c \
- daemon/service.h \
+ daemon/static_threads.h \
+ daemon/static_threads.c \
daemon/commands.c \
daemon/commands.h \
daemon/unit_test.c \
@@ -904,25 +899,27 @@ NETDATA_FILES = \
if FREEBSD
NETDATA_FILES += \
+ daemon/static_threads_freebsd.c \
$(FREEBSD_PLUGIN_FILES) \
$(NULL)
endif
if MACOS
NETDATA_FILES += \
+ daemon/static_threads_macos.c \
$(MACOS_PLUGIN_FILES) \
$(NULL)
endif
if LINUX
NETDATA_FILES += \
+ daemon/static_threads_linux.c \
$(CGROUPS_PLUGIN_FILES) \
$(DISKSPACE_PLUGIN_FILES) \
$(TIMEX_PLUGIN_FILES) \
$(PROC_PLUGIN_FILES) \
$(TC_PLUGIN_FILES) \
$(NULL)
-
endif
NETDATA_COMMON_LIBS = \