summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorVladimir Kobal <vlad@prokk.net>2020-04-10 12:26:36 +0300
committerGitHub <noreply@github.com>2020-04-10 12:26:36 +0300
commit231d19351d0ea20aa66fd204215cbb24f34d7575 (patch)
treee3ed26be7d8ea4ba3b07a29c77bf05bc67b73a43 /Makefile.am
parent764a0676e82c89b4a4516a31a7782ea606071fa5 (diff)
Show internal stats for the exporting engine (#8635)
* Add a print function for internal exporting statistics * Send statistics for simple connectors * Flush sending buffers on failures * Send statistics for the Kinesis connector * Send statistics for the MongoDB connector * Add unit tests
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 28debf3999..be84fc09ac 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -873,6 +873,8 @@ if ENABLE_UNITTESTS
-Wl,--wrap=recv \
-Wl,--wrap=send \
-Wl,--wrap=connect_to_one_of \
+ -Wl,--wrap=create_main_rusage_chart \
+ -Wl,--wrap=send_main_rusage \
$(TEST_LDFLAGS) \
$(NULL)
exporting_tests_exporting_engine_testdriver_LDADD = $(NETDATA_COMMON_LIBS) $(TEST_LIBS)