summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMarkos Fountoulakis <44345837+mfundul@users.noreply.github.com>2019-12-05 00:21:22 +0200
committerChris Akritidis <43294513+cakrit@users.noreply.github.com>2019-12-04 14:21:22 -0800
commit16f835489c1a93b5dbd84747c52c883f43b716f0 (patch)
treefe91de0b4fa0d85f52870550e410bc1d0dead434 /Makefile.am
parenta7a88ba2723242da1de6626df0541d2091bd9b2b (diff)
Implement netdata command server and cli tool (#7325)
* Checkpoint commit (POC) * Implemented command server in the daemon * Add netdatacli implementation * Added prints in command server setup functions * Make libuv version 1 a hard dependency for the agent * Additional documentation * Improved accuracy of names and documentation * Fixed documentation * Fixed buffer overflow * Added support for exit status in cli. Added prefixes for exit code, stdout and stderr. Fixed parsers. * Fix compilation errors * Fix compile errors * Fix compile errors * Fix compile error * Fix linker error for muslc
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am20
1 files changed, 20 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 3ecdb14064..accf2ac691 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -482,6 +482,8 @@ DAEMON_FILES = \
daemon/main.h \
daemon/signals.c \
daemon/signals.h \
+ daemon/commands.c \
+ daemon/commands.h \
daemon/unit_test.c \
daemon/unit_test.h \
$(NULL)
@@ -537,6 +539,13 @@ NETDATA_COMMON_LIBS = \
$(OPTIONAL_JSONC_LIBS) \
$(NULL)
+NETDATACLI_FILES = \
+ daemon/commands.h \
+ $(LIBNETDATA_FILES) \
+ cli/cli.c \
+ cli/cli.h \
+ $(NULL)
+
sbin_PROGRAMS += netdata
netdata_SOURCES = $(NETDATA_FILES)
netdata_LDADD = \
@@ -548,6 +557,17 @@ else
netdata_LINK = $(CCLD) $(CFLAGS) $(LDFLAGS) -o $@
endif
+sbin_PROGRAMS += netdatacli
+netdatacli_SOURCES = $(NETDATACLI_FILES)
+netdatacli_LDADD = \
+ $(NETDATA_COMMON_LIBS) \
+ $(NULL)
+if ENABLE_CXX_LINKER
+ netdatacli_LINK = $(CXXLD) $(CXXFLAGS) $(LDFLAGS) -o $@
+else
+ netdatacli_LINK = $(CCLD) $(CFLAGS) $(LDFLAGS) -o $@
+endif
+
if ENABLE_PLUGIN_APPS
plugins_PROGRAMS += apps.plugin
apps_plugin_SOURCES = $(APPS_PLUGIN_FILES)