summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMarkos Fountoulakis <44345837+mfundul@users.noreply.github.com>2020-05-14 11:57:20 +0300
committerGitHub <noreply@github.com>2020-05-14 11:57:20 +0300
commit6393b2f535c993de9f341d2245ad8ba327694281 (patch)
treed53a5b854c4075908c4c3921c372b9d75ba9617d /Makefile.am
parenta606a27f164b1c704d850c838a7b89d6c6e0c17c (diff)
Improve the impact of health code on netdata scalability (#8407)
* Add support for spawning processes without pipes. * Port health_alarm_execute() from mypopen() to netdata_spawn() * Make alarm notifications asynchronous within a single health thread iteration * Initial version of spawn server. * preliminary integration of spawn client with health
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 8a6de4e0e8..da722b1670 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -112,6 +112,7 @@ SUBDIRS += \
web \
claim \
aclk \
+ spawn \
$(NULL)
@@ -497,6 +498,13 @@ endif
+SPAWN_PLUGIN_FILES = \
+ spawn/spawn.c \
+ spawn/spawn_server.c \
+ spawn/spawn_client.c \
+ spawn/spawn.h \
+ $(NULL)
+
EXPORTING_ENGINE_FILES = \
exporting/exporting_engine.c \
exporting/exporting_engine.h \
@@ -595,6 +603,7 @@ NETDATA_FILES = \
$(WEB_PLUGIN_FILES) \
$(CLAIM_FILES) \
$(ACLK_FILES) \
+ $(SPAWN_PLUGIN_FILES) \
$(NULL)
if FREEBSD