summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorTimotej S <6674623+underhood@users.noreply.github.com>2021-09-29 17:53:53 +0200
committerGitHub <noreply@github.com>2021-09-29 17:53:53 +0200
commitdad48421a6b3482f9cb71973885cf1160408855f (patch)
treecc66313a014c333e8baa09d3e34f46c98e4ce96b /Makefile.am
parent8d0a2384412882cf9b641f17cf4e0602db4cce4d (diff)
Makes New Cloud architecture optional for ACLK-NG (#11587)
ACLK-NG supports both new and old cloud protocol. Protobuf and C++ compiler are required only for new cloud protocol. There is no reason to skip building whole ACLK-NG when protobuf is missing.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am16
1 files changed, 11 insertions, 5 deletions
diff --git a/Makefile.am b/Makefile.am
index 823dea0995..7956558e20 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -588,10 +588,6 @@ ACLK_NG_FILES = \
aclk/aclk_rx_msgs.h \
aclk/https_client.c \
aclk/https_client.h \
- aclk/aclk_charts_api.c \
- aclk/aclk_charts_api.h \
- aclk/aclk_alarm_api.c \
- aclk/aclk_alarm_api.h \
mqtt_websockets/src/mqtt_wss_client.c \
mqtt_websockets/src/include/mqtt_wss_client.h \
mqtt_websockets/src/mqtt_wss_log.c \
@@ -602,7 +598,15 @@ ACLK_NG_FILES = \
mqtt_websockets/c-rbuf/include/ringbuffer.h \
mqtt_websockets/c-rbuf/src/ringbuffer_internal.h \
mqtt_websockets/MQTT-C/src/mqtt.c \
- mqtt_websockets/MQTT-C/include/mqtt.h \
+ mqtt_websockets/MQTT-C/include/mqtt.h
+ $(NULL)
+
+if ENABLE_NEW_CLOUD_PROTOCOL
+ACLK_NG_FILES += \
+ aclk/aclk_charts_api.c \
+ aclk/aclk_charts_api.h \
+ aclk/aclk_alarm_api.c \
+ aclk/aclk_alarm_api.h \
aclk/schema-wrappers/connection.cc \
aclk/schema-wrappers/connection.h \
aclk/schema-wrappers/node_connection.cc \
@@ -712,6 +716,8 @@ aclk/aclk-schemas/proto/nodeinstance/info/v1/info.pb.cc \
aclk/aclk-schemas/proto/nodeinstance/info/v1/info.pb.h: aclk/aclk-schemas/proto/nodeinstance/info/v1/info.proto
$(PROTOC) -I=aclk/aclk-schemas --cpp_out=$(builddir)/aclk/aclk-schemas $^
+endif #ENABLE_NEW_CLOUD_PROTOCOL
+
endif #ACLK_NG
if ENABLE_ACLK