summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorCosta Tsaousis <costa@netdata.cloud>2022-08-01 21:47:14 +0300
committerGitHub <noreply@github.com>2022-08-01 21:47:14 +0300
commitccf0f6b6f48f12a30c45dd31c2d4c279e660e304 (patch)
tree5f2ca726e2b30378c637d7652439688a0937ad08 /Makefile.am
parent8db672d4e685d49853c61ae988d7b983ef1fa5d9 (diff)
/api/v1/weights endpoint (#13449)
* /api/v1/weights endpoints * high resolution anomaly rate in parallel with queries; points and options in /api/v1/weights reflect the truth * context printing * merged metric_correlations with weights API; added parameter tier to select the tier to run the query; weight api now returns points per tier; added swagger info about weights api * moved metric_correlations files to web/api/queries as weights * added contexts filtering; renamed correlated_dimensions; weights API is always enabled; code cleanup * allow returning zero results
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 5eefdc13cf..b962bb7973 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -473,8 +473,6 @@ RRD_PLUGIN_FILES = \
database/sqlite/sqlite3.h \
database/KolmogorovSmirnovDist.c \
database/KolmogorovSmirnovDist.h \
- database/metric_correlations.c \
- database/metric_correlations.h \
$(NULL)
database/sqlite/sqlite3.$(OBJEXT) : CFLAGS += -Wno-cast-function-type
@@ -599,6 +597,8 @@ API_PLUGIN_FILES = \
web/api/queries/stddev/stddev.h \
web/api/queries/sum/sum.c \
web/api/queries/sum/sum.h \
+ web/api/queries/weights.c \
+ web/api/queries/weights.h \
web/api/formatters/rrd2json.c \
web/api/formatters/rrd2json.h \
web/api/formatters/csv/csv.c \