summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorTimotej S <6674623+underhood@users.noreply.github.com>2022-12-13 12:32:05 +0700
committerGitHub <noreply@github.com>2022-12-13 12:32:05 +0700
commita749ab00a63b229d99f6bc82a965206e5481db3e (patch)
tree6d5ad0676338a7e6c1ce767229befb7249d2a246 /Makefile.am
parent340459e43c1d286a5f08232b51185b06874ddbf5 (diff)
MQTT 5 publish topic alias support (#14067)
* mqtt_websockets bumps version * use the new topic alias support in netdata
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 5 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 5e16052374..32b30b1a4c 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -733,9 +733,12 @@ libmqttwebsockets_a_SOURCES = \
mqtt_websockets/c-rbuf/include/ringbuffer.h \
mqtt_websockets/c-rbuf/src/ringbuffer_internal.h \
mqtt_websockets/MQTT-C/src/mqtt.c \
- mqtt_websockets/MQTT-C/include/mqtt.h
+ mqtt_websockets/MQTT-C/include/mqtt.h \
+ mqtt_websockets/c_rhash/src/c_rhash.c \
+ mqtt_websockets/c_rhash/include/c_rhash.h \
+ mqtt_websockets/c_rhash/src/c_rhash_internal.h
-libmqttwebsockets_a_CFLAGS = $(CFLAGS) -DMQTT_WSS_CUSTOM_ALLOC -DRBUF_CUSTOM_MALLOC -I$(srcdir)/aclk/helpers
+libmqttwebsockets_a_CFLAGS = $(CFLAGS) -DMQTT_WSS_CUSTOM_ALLOC -DRBUF_CUSTOM_MALLOC -I$(srcdir)/aclk/helpers -I$(srcdir)/mqtt_websockets/c_rhash/include
mqtt_websockets/src/mqtt_wss_client.$(OBJEXT) : CFLAGS += -Wno-unused-result