summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorDim-P <Dim-P@users.noreply.github.com>2022-10-25 13:41:47 +0100
committerGitHub <noreply@github.com>2022-10-25 13:41:47 +0100
commit992f188f3b2266461d43b5989ed6384ecac16066 (patch)
tree0ea94abb5edd0fb8f29257649d92f5084ad2418b /Makefile.am
parent2da50b591b1b6a5450f84252e619cdcb69360797 (diff)
Suppress ML and dlib ABI warnings (#13875)
* Suppress dlib ABI GCC warnings * Suppress ml ABI GCC warnings
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 7 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 0d8b310bfd..bea807f3b1 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -256,7 +256,13 @@ ML_FILES += \
$(NULL)
# Disable warnings from dlib library
-ml/dlib/dlib/all/source.$(OBJEXT) : CXXFLAGS += -Wno-sign-compare -Wno-type-limits -Wno-aggressive-loop-optimizations -Wno-stringop-overflow
+ml/dlib/dlib/all/source.$(OBJEXT) : CXXFLAGS += -Wno-sign-compare -Wno-type-limits -Wno-aggressive-loop-optimizations -Wno-stringop-overflow -Wno-psabi
+
+# Disable ml warnings
+ml/Dimension.$(OBJEXT) : CXXFLAGS += -Wno-psabi
+ml/Host.$(OBJEXT) : CXXFLAGS += -Wno-psabi
+ml/KMeans.$(OBJEXT) : CXXFLAGS += -Wno-psabi
+ml/ml.$(OBJEXT) : CXXFLAGS += -Wno-psabi
endif