summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorEmmanuel Vasilakis <mrzammler@mm.st>2022-07-07 22:15:23 +0300
committerGitHub <noreply@github.com>2022-07-07 22:15:23 +0300
commit7f144682083bb334d38a527e7c9bd4bc736575eb (patch)
tree1a59e135629aaad7e7718c904f1960670d13752f /Makefile.am
parent19d9a0030db7d8ff6e43f2ff76cea7f9761c6cd7 (diff)
Silence compile warnings on external source (#13332)
* silence compile warnings * also silence from mqtt
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 6 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 16230892f1..3febc8cc86 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -260,7 +260,7 @@ ML_FILES += \
$(NULL)
# Disable warnings from dlib library
-ml/kmeans/dlib/dlib/all/source.$(OBJEXT) : CXXFLAGS += -Wno-sign-compare -Wno-type-limits -Wno-aggressive-loop-optimizations
+ml/kmeans/dlib/dlib/all/source.$(OBJEXT) : CXXFLAGS += -Wno-sign-compare -Wno-type-limits -Wno-aggressive-loop-optimizations -Wno-stringop-overflow
endif
@@ -474,6 +474,9 @@ RRD_PLUGIN_FILES = \
database/metric_correlations.h \
$(NULL)
+database/sqlite/sqlite3.$(OBJEXT) : CFLAGS += -Wno-cast-function-type
+database/KolmogorovSmirnovDist.$(OBJEXT) : CFLAGS += -Wno-maybe-uninitialized
+
if ENABLE_DBENGINE
RRD_PLUGIN_FILES += \
database/engine/rrdengine.c \
@@ -669,6 +672,8 @@ ACLK_FILES = \
aclk/schema-wrappers/schema_wrapper_utils.h \
$(NULL)
+mqtt_websockets/src/mqtt_wss_client.$(OBJEXT) : CFLAGS += -Wno-unused-result
+
ACLK_PROTO_DEFINITIONS = \
aclk/aclk-schemas/proto/aclk/v1/lib.proto \
aclk/aclk-schemas/proto/agent/v1/disconnect.proto \