summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorvkalintiris <vasilis@netdata.cloud>2023-01-04 14:51:25 +0200
committerGitHub <noreply@github.com>2023-01-04 14:51:25 +0200
commit78359cd375d0b2c285741e6f934a681d0a0c3c15 (patch)
tree2d5264325510b663d9e87ca62a38fad187e3a713 /Makefile.am
parentdf379e45fbaddf825f1f7972a75ae3f3daf80097 (diff)
Refactor ML code and add support for multiple KMeans models (#14198)
* Add profile.plugin Creates the specified number of charts/dimensions, and supports backfilling with pseudo-historical data. * Bump * Remove wrongly merged line. * Use the number of models specified from the config section. * Add option to consult all ML models. * Remove profiling option consuming all models. * Add underscore after chart name prefix. * prediction -> dimensions chart * reorder funcs * Split charts across types with correct priority * Ignore training request when chart is under replication. * Track global number of models consulted. * Cleanup config. * initial readme updates * fix readme * readme * Fix function definition when ML is disabled. * Add dummy ml_chart_update_{begin,end} * Remove profile_plugin * Define chart priorities under collectors/all.h * s/curr_t/current_time/ * Use libnetdata's lock/thread wrappers. * Fix autotools & cmake builds. * Delete ML dimensions & charts. * Let users of buffer preprocessing to handle memory. * Add separate API calls to start/stop ML threads. Co-authored-by: Andrew Maguire <andrewm4894@gmail.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am18
1 files changed, 5 insertions, 13 deletions
diff --git a/Makefile.am b/Makefile.am
index e88b1b59f0..e900755999 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -236,10 +236,15 @@ ML_FILES += \
ml/ADCharts.cc \
ml/Config.h \
ml/Config.cc \
+ ml/Chart.cc \
+ ml/Chart.h \
+ ml/Stats.h \
ml/Dimension.cc \
ml/Dimension.h \
ml/Host.h \
ml/Host.cc \
+ ml/Mutex.h \
+ ml/Queue.h \
ml/Query.h \
ml/KMeans.h \
ml/KMeans.cc \
@@ -262,13 +267,6 @@ ml/ml.$(OBJEXT) : CXXFLAGS += -Wno-psabi
endif
-
-if ENABLE_ML_TESTS
-ML_TESTS_FILES = \
- ml/SamplesBufferTests.cc \
- $(NULL)
-endif
-
IDLEJITTER_PLUGIN_FILES = \
collectors/idlejitter.plugin/plugin_idlejitter.c \
$(NULL)
@@ -920,7 +918,6 @@ NETDATA_FILES = \
$(EXPORTING_ENGINE_FILES) \
$(HEALTH_PLUGIN_FILES) \
$(ML_FILES) \
- $(ML_TESTS_FILES) \
$(IDLEJITTER_PLUGIN_FILES) \
$(PLUGINSD_PLUGIN_FILES) \
$(REGISTRY_PLUGIN_FILES) \
@@ -1008,11 +1005,6 @@ if ENABLE_ACLK
$(NULL)
endif
-if ENABLE_ML_TESTS
- netdata_LDADD += $(OPTIONAL_ML_TESTS_LIBS) \
- $(NULL)
-endif
-
netdata_LINK = $(CXXLD) $(CXXFLAGS) $(LDFLAGS) -o $@
sbin_PROGRAMS += netdatacli