summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorvkalintiris <vasilis@netdata.cloud>2022-12-21 15:03:05 +0200
committerGitHub <noreply@github.com>2022-12-21 15:03:05 +0200
commit689dc6b7fbbf495ce3e020dcff0d014a8d338c52 (patch)
tree1f458a3218798b53809d0868a82fcad1a20b1e32 /Makefile.am
parentfe386aad57f24574783f4c68bab433a5cdfe6f64 (diff)
Refactor ML code and add support for multiple KMeans models. (#14065)
* Add profile.plugin Creates the specified number of charts/dimensions, and supports backfilling with pseudo-historical data. * Bump * Remove wrongly merged line. * Use the number of models specified from the config section. * Add option to consult all ML models. * Remove profiling option consuming all models. * Add underscore after chart name prefix. * prediction -> dimensions chart * reorder funcs * Split charts across types with correct priority * Ignore training request when chart is under replication. * Track global number of models consulted. * Cleanup config. * initial readme updates * fix readme * readme * Fix function definition when ML is disabled. * Add dummy ml_chart_update_{begin,end} * Remove profile_plugin * Define chart priorities under collectors/all.h * s/curr_t/current_time/ Co-authored-by: Andrew Maguire <andrewm4894@gmail.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am17
1 files changed, 4 insertions, 13 deletions
diff --git a/Makefile.am b/Makefile.am
index e88b1b59f0..f29012769d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -236,10 +236,14 @@ ML_FILES += \
ml/ADCharts.cc \
ml/Config.h \
ml/Config.cc \
+ ml/Chart.cc \
+ ml/Chart.h \
+ ml/Stats.h \
ml/Dimension.cc \
ml/Dimension.h \
ml/Host.h \
ml/Host.cc \
+ ml/Queue.h \
ml/Query.h \
ml/KMeans.h \
ml/KMeans.cc \
@@ -262,13 +266,6 @@ ml/ml.$(OBJEXT) : CXXFLAGS += -Wno-psabi
endif
-
-if ENABLE_ML_TESTS
-ML_TESTS_FILES = \
- ml/SamplesBufferTests.cc \
- $(NULL)
-endif
-
IDLEJITTER_PLUGIN_FILES = \
collectors/idlejitter.plugin/plugin_idlejitter.c \
$(NULL)
@@ -920,7 +917,6 @@ NETDATA_FILES = \
$(EXPORTING_ENGINE_FILES) \
$(HEALTH_PLUGIN_FILES) \
$(ML_FILES) \
- $(ML_TESTS_FILES) \
$(IDLEJITTER_PLUGIN_FILES) \
$(PLUGINSD_PLUGIN_FILES) \
$(REGISTRY_PLUGIN_FILES) \
@@ -1008,11 +1004,6 @@ if ENABLE_ACLK
$(NULL)
endif
-if ENABLE_ML_TESTS
- netdata_LDADD += $(OPTIONAL_ML_TESTS_LIBS) \
- $(NULL)
-endif
-
netdata_LINK = $(CXXLD) $(CXXFLAGS) $(LDFLAGS) -o $@
sbin_PROGRAMS += netdatacli