summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorTimotej S <6674623+underhood@users.noreply.github.com>2021-08-17 14:48:52 +0200
committerGitHub <noreply@github.com>2021-08-17 14:48:52 +0200
commit590c5aecd5479d35640e7f3ed0607c80d1f30492 (patch)
tree732dc324e57b911cbde795cb4c0bee0adb281d99 /Makefile.am
parent1610975ddfed6876716cac979b22d60c1989cb6b (diff)
Adds NodeInstanceInfo internal API (#11419)
* Adds NodeInstanceInfo internal API
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 8c11b6251a..08c7662420 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -595,6 +595,8 @@ ACLK_NG_FILES = \
aclk/schema-wrappers/chart_stream.h \
aclk/schema-wrappers/chart_config.cc \
aclk/schema-wrappers/chart_config.h \
+ aclk/schema-wrappers/node_info.cc \
+ aclk/schema-wrappers/node_info.h \
aclk/schema-wrappers/schema_wrappers.h \
aclk/schema-wrappers/schema_wrapper_utils.cc \
aclk/schema-wrappers/schema_wrapper_utils.h \
@@ -632,6 +634,8 @@ ACLK_NG_PROTO_BUILT_FILES = aclk/aclk-schemas/proto/agent/v1/connection.pb.cc \
aclk/aclk-schemas/proto/chart/v1/config.pb.h \
aclk/aclk-schemas/proto/aclk/v1/lib.pb.cc \
aclk/aclk-schemas/proto/aclk/v1/lib.pb.h \
+ aclk/aclk-schemas/proto/nodeinstance/info/v1/info.pb.cc \
+ aclk/aclk-schemas/proto/nodeinstance/info/v1/info.pb.h \
$(NULL)
BUILT_SOURCES += $(ACLK_NG_PROTO_BUILT_FILES)
@@ -670,6 +674,10 @@ aclk/aclk-schemas/proto/aclk/v1/lib.pb.cc \
aclk/aclk-schemas/proto/aclk/v1/lib.pb.h: aclk/aclk-schemas/proto/aclk/v1/lib.proto
$(PROTOC) -I=aclk/aclk-schemas --cpp_out=$(builddir)/aclk/aclk-schemas $^
+aclk/aclk-schemas/proto/nodeinstance/info/v1/info.pb.cc \
+aclk/aclk-schemas/proto/nodeinstance/info/v1/info.pb.h: aclk/aclk-schemas/proto/nodeinstance/info/v1/info.proto
+ $(PROTOC) -I=aclk/aclk-schemas --cpp_out=$(builddir)/aclk/aclk-schemas $^
+
endif #ACLK_NG
if ENABLE_ACLK