summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorTimotej S <6674623+underhood@users.noreply.github.com>2022-12-14 10:31:34 +0700
committerGitHub <noreply@github.com>2022-12-14 10:31:34 +0700
commit5847aeadcce2ea03dba23fc7baabcd4d04dfecb9 (patch)
tree284f50fc9390cc494c3480f829797717f4475972 /Makefile.am
parentac52d5de53804d336f2ab63d19aaa7c6a15ce028 (diff)
expose ACLK SSL KeyLog interface for developers (#14109)
* add possibility to decypt trafic for developers for debugging purposes * requires netdata to be explicitly built with this feature enabled
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 32b30b1a4c..3898d01fda 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -740,6 +740,10 @@ libmqttwebsockets_a_SOURCES = \
libmqttwebsockets_a_CFLAGS = $(CFLAGS) -DMQTT_WSS_CUSTOM_ALLOC -DRBUF_CUSTOM_MALLOC -I$(srcdir)/aclk/helpers -I$(srcdir)/mqtt_websockets/c_rhash/include
+if MQTT_WSS_DEBUG
+libmqttwebsockets_a_CFLAGS += -DMQTT_WSS_DEBUG
+endif
+
mqtt_websockets/src/mqtt_wss_client.$(OBJEXT) : CFLAGS += -Wno-unused-result
ACLK_PROTO_DEFINITIONS = \