summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorCosta Tsaousis <costa@netdata.cloud>2023-02-09 20:27:05 +0200
committerGitHub <noreply@github.com>2023-02-09 20:27:05 +0200
commit414f416c5d290db3c3eed9073258c834fac7f2f7 (patch)
treeaeed0a2619a1f42c60ec816311d1dd10c8e5ccc1 /Makefile.am
parent8043106b60ec3d8d32b3a9ff3ef53991e73d9037 (diff)
Virtual hosts for data collection (#14464)
* support multiple hosts at pluginsd structures * cleanup obsolete code * use a lookup hashtable to quickly find the keyword to execute, without traversing the whole linked list of keywords * more cleanup * move new hash function to inlined.h * minimize comparisons, eliminate a pre-parsing of the first keyword for each line * cleanup parser from old code * move parser into libnetdata * unique entries in parser keywords hashtable * move all hashing functions to inlined.h, name their sources, simple_hash() now defaults to FNV1a, it was FNV1 * small_hash() for parser * plugins.d now can switch hosts, and also create/update them * update hash function and hashtable size * updated message * unittest all hashing functions * reset the chart when setting a new host * remove host tags * enable archived hosts when a collector pushes host info * do not need localhost to swtich to localhost * disable ARAL and OWA with -DFSANITIZE_ADDRESS=1
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 2 insertions, 7 deletions
diff --git a/Makefile.am b/Makefile.am
index 3ce9cb36fe..056e4edba2 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -107,7 +107,6 @@ SUBDIRS += \
streaming \
web \
claim \
- parser \
spawn \
$(NULL)
@@ -160,6 +159,8 @@ LIBNETDATA_FILES = \
libnetdata/log/log.h \
libnetdata/onewayalloc/onewayalloc.c \
libnetdata/onewayalloc/onewayalloc.h \
+ libnetdata/parser/parser.c \
+ libnetdata/parser/parser.h \
libnetdata/popen/popen.c \
libnetdata/popen/popen.h \
libnetdata/procfile/procfile.c \
@@ -677,11 +678,6 @@ CLAIM_FILES = \
claim/claim.h \
$(NULL)
-PARSER_FILES = \
- parser/parser.c \
- parser/parser.h \
- $(NULL)
-
if ENABLE_ACLK
ACLK_FILES = \
aclk/aclk_util.c \
@@ -949,7 +945,6 @@ NETDATA_FILES = \
$(STATSD_PLUGIN_FILES) \
$(WEB_PLUGIN_FILES) \
$(CLAIM_FILES) \
- $(PARSER_FILES) \
$(ACLK_ALWAYS_BUILD_FILES) \
$(ACLK_FILES) \
$(SPAWN_PLUGIN_FILES) \