summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorCosta Tsaousis <costa@netdata.cloud>2023-02-22 22:30:40 +0200
committerGitHub <noreply@github.com>2023-02-22 22:30:40 +0200
commit1cfad181a8cdcafc04d6f2d52aa0ffb5e57e182a (patch)
treebb753be9e16256ef2fe420d9ad24cd27787ee8fc /Makefile.am
parent7cd5570b49c5f156c944766dda7238611a969ff0 (diff)
/api/v2/data - multi-host/context/instance/dimension/label queries (#14564)
* fundamentals for having /api/v2/ working * use an atomic to prevent writing to internal pipe too much * first attempt of multi-node, multi-context, multi-chart, multi-dimension queries * v2 jsonwrap * first attempt for group by * cleaned up RRDR and fixed group by * improvements to /api/v2/api * query instance may be realloced, so pointers to it get invalid; solved memory leaks * count of quried metrics in summary information * provide detailed information about selected, excluded, queried and failed metrics for each entity * select instances by fqdn too * add timing information to json output * link charts to rrdcontexts, if a query comes in and it is found unlinked * calculate min, max, sum, average, volume, count per metric * api v2 parameters naming * renders alerts and units * render machine_guid and node_id in all sections it is relevant * unified keys * group by now takes into account units and when there are multiple units involved, it creates a dimension per unit * request and detailed are hidden behind an option * summary includes only a flattened list of alerts * alert counts per host and instance * count of grouped metrics per dimension * added contexts to summary * added chart title * added dimension priorities and chart type * support for multiple group by at the same time * minor fixes * labels are now a tree * keys uniformity * filtering by alerts, both having a specific alert and having a specific alert in a specific status * added scope of hosts and contexts * count of instances on contexts and hosts * make the api return valid responses even when the response contains no data * calculate average and contribution % for every item in the summary * fix compilation warnings * fix compilation warnings - again
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 056e4edba2..ead4b54719 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -628,8 +628,12 @@ API_PLUGIN_FILES = \
web/api/formatters/rrdset2json.h \
web/api/health/health_cmdapi.c \
web/api/health/health_cmdapi.h \
+ web/api/web_api.c \
+ web/api/web_api.h \
web/api/web_api_v1.c \
web/api/web_api_v1.h \
+ web/api/web_api_v2.c \
+ web/api/web_api_v2.h \
$(NULL)
STREAMING_PLUGIN_FILES = \