summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorVladimir Kobal <vlad@prokk.net>2019-02-13 11:34:58 +0200
committerChris Akritidis <43294513+cakrit@users.noreply.github.com>2019-02-13 10:34:58 +0100
commitea0e0f8f5ea44c0f5f5b4aadffede1c1b43b7d1e (patch)
tree885b2c79f1ab6412cb40325c31ec0f38e271fb0b /Makefile.am
parent2f71662ac40e056efea2c5f2badf4b5d9df77fc7 (diff)
Split nfacct plugin into separate process (#5361)
* Prepare build configuration * Prepare plugin for separating * Add command line options * Add debug messages * Use text API * Minor fixes * Update the documentation * Minor documentation formatting * Fix LGTM alerts * Fix building with CMake * Add nfacct and cups plugins to apps.plugin groups
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am13
1 files changed, 10 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 376ccf178b..15777dd2ca 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -221,7 +221,7 @@ CUPS_PLUGIN_FILES = \
NFACCT_PLUGIN_FILES = \
collectors/nfacct.plugin/plugin_nfacct.c \
- collectors/nfacct.plugin/plugin_nfacct.h \
+ $(LIBNETDATA_FILES) \
$(NULL)
PROC_PLUGIN_FILES = \
@@ -449,7 +449,6 @@ if LINUX
NETDATA_FILES += \
$(CGROUPS_PLUGIN_FILES) \
$(DISKSPACE_PLUGIN_FILES) \
- $(NFACCT_PLUGIN_FILES) \
$(PROC_PLUGIN_FILES) \
$(TC_PLUGIN_FILES) \
$(NULL)
@@ -467,7 +466,6 @@ sbin_PROGRAMS += netdata
netdata_SOURCES = $(NETDATA_FILES)
netdata_LDADD = \
$(NETDATA_COMMON_LIBS) \
- $(OPTIONAL_NFACCT_LIBS) \
$(NULL)
if ENABLE_PLUGIN_APPS
@@ -504,3 +502,12 @@ if ENABLE_PLUGIN_CUPS
$(OPTIONAL_CUPS_LIBS) \
$(NULL)
endif
+
+if ENABLE_PLUGIN_NFACCT
+ plugins_PROGRAMS += nfacct.plugin
+ nfacct_plugin_SOURCES = $(NFACCT_PLUGIN_FILES)
+ nfacct_plugin_LDADD = \
+ $(NETDATA_COMMON_LIBS) \
+ $(OPTIONAL_NFACCT_LIBS) \
+ $(NULL)
+endif