summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorvkalintiris <vasilis@netdata.cloud>2021-11-03 09:20:19 +0200
committerGitHub <noreply@github.com>2021-11-03 09:20:19 +0200
commitd101b9b7f6d5e0742d453d3ff976b4b2be1d73e0 (patch)
treeaf7e492d6a955eb7317adb62c9f183d91b97f247 /Makefile.am
parentc0df286063fbe9ad200e8882bc402809dd4b64b3 (diff)
Disable C++ warnings from dlib library. (#11738)
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 6 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 0cc3111aa3..0fef853e1b 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -241,6 +241,7 @@ ML_FILES = \
$(NULL)
if ENABLE_ML
+
ML_FILES += \
ml/BitBufferCounter.h \
ml/BitBufferCounter.cc \
@@ -264,8 +265,13 @@ ML_FILES += \
ml/ml.cc \
ml/ml-private.h \
$(NULL)
+
+# Disable warnings from dlib library
+ml/kmeans/dlib/dlib/all/source.$(OBJEXT) : CXXFLAGS += -Wno-sign-compare -Wno-type-limits
+
endif
+
if ENABLE_ML_TESTS
ML_TESTS_FILES = \
ml/kmeans/Tests.cc \