summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorvkalintiris <vasilis@netdata.cloud>2022-05-02 17:59:40 +0300
committerGitHub <noreply@github.com>2022-05-02 17:59:40 +0300
commitb6d2a3662dfb683e9e95203ef3b21f8e31238b06 (patch)
treeedfb6db2fa5cc932b36834e6b41017bc8182d8d8 /Makefile.am
parentdb9b85a9cb9eac7b55a4145207ccc407e4064f4c (diff)
Make atomics a hard-dep. (#12730)
They are used extensively throughout our code base, and not having support for them does not generate a thread-safe agent.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am14
1 files changed, 3 insertions, 11 deletions
diff --git a/Makefile.am b/Makefile.am
index 0aa4d639ed..9f60349588 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -28,7 +28,6 @@ EXTRA_DIST = \
.eslintrc \
.github/CODEOWNERS \
build/m4/jemalloc.m4 \
- build/m4/ax_c___atomic.m4 \
build/m4/ax_check_enable_debug.m4 \
build/m4/ax_c_mallinfo.m4 \
build/m4/ax_gcc_func_attribute.m4 \
@@ -941,22 +940,15 @@ if ENABLE_ML_TESTS
$(NULL)
endif
-if ENABLE_CXX_LINKER
- netdata_LINK = $(CXXLD) $(CXXFLAGS) $(LDFLAGS) -o $@
-else
- netdata_LINK = $(CCLD) $(CFLAGS) $(LDFLAGS) -o $@
-endif
+netdata_LINK = $(CXXLD) $(CXXFLAGS) $(LDFLAGS) -o $@
sbin_PROGRAMS += netdatacli
netdatacli_SOURCES = $(NETDATACLI_FILES)
netdatacli_LDADD = \
$(NETDATA_COMMON_LIBS) \
$(NULL)
-if ENABLE_CXX_LINKER
- netdatacli_LINK = $(CXXLD) $(CXXFLAGS) $(LDFLAGS) -o $@
-else
- netdatacli_LINK = $(CCLD) $(CFLAGS) $(LDFLAGS) -o $@
-endif
+
+netdatacli_LINK = $(CXXLD) $(CXXFLAGS) $(LDFLAGS) -o $@
if ENABLE_PLUGIN_APPS
plugins_PROGRAMS += apps.plugin