summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorTimotej S <6674623+underhood@users.noreply.github.com>2023-01-09 08:51:00 +0700
committerGitHub <noreply@github.com>2023-01-09 08:51:00 +0700
commit967208aa05307a04cf70e544a4e353899f347fb6 (patch)
treea436eabb7e09e280ec1a1f93feeb70dc9257e814 /Makefile.am
parentbadd17fb4eec602244d4c343dd25cc00ad182686 (diff)
MQTT5 Topic Alias (#14148)
* bump websockets * add new files to makefile * set topic aliases for used topics
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 5 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index e900755999..990770f7d4 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -731,9 +731,12 @@ libmqttwebsockets_a_SOURCES = \
mqtt_websockets/c-rbuf/include/ringbuffer.h \
mqtt_websockets/c-rbuf/src/ringbuffer_internal.h \
mqtt_websockets/MQTT-C/src/mqtt.c \
- mqtt_websockets/MQTT-C/include/mqtt.h
+ mqtt_websockets/MQTT-C/include/mqtt.h \
+ mqtt_websockets/c_rhash/src/c_rhash.c \
+ mqtt_websockets/c_rhash/include/c_rhash.h \
+ mqtt_websockets/c_rhash/src/c_rhash_internal.h
-libmqttwebsockets_a_CFLAGS = $(CFLAGS) -DMQTT_WSS_CUSTOM_ALLOC -DRBUF_CUSTOM_MALLOC -I$(srcdir)/aclk/helpers
+libmqttwebsockets_a_CFLAGS = $(CFLAGS) -DMQTT_WSS_CUSTOM_ALLOC -DRBUF_CUSTOM_MALLOC -I$(srcdir)/aclk/helpers -I$(srcdir)/mqtt_websockets/c_rhash/include
if MQTT_WSS_DEBUG
libmqttwebsockets_a_CFLAGS += -DMQTT_WSS_DEBUG