summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorEmmanuel Vasilakis <mrzammler@mm.st>2023-03-20 10:46:48 +0200
committerGitHub <noreply@github.com>2023-03-20 10:46:48 +0200
commit6ee42875c3303ee2056c753a06c622aeb2b2dc84 (patch)
tree7038587ce81a19016da91108ffd0c9c8359ec99c /Makefile.am
parentd31cd412c5968021c48891942187a432f1fd50e7 (diff)
Bundle libyaml (#14704)
* bundle libyaml * remove comment * .github/workflows/coverity.yml * add to coverity and tests * add deps * add to netdata.spec.in * add to contrib/debia/control * remove extra gentoo libyaml
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index a922d4def5..05efd16983 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -73,6 +73,8 @@ dist_noinst_DATA = \
packaging/installer/UPDATE.md \
packaging/jsonc.checksums \
packaging/jsonc.version \
+ packaging/yaml.checksums \
+ packaging/yaml.version \
packaging/libbpf.checksums \
packaging/libbpf.version \
packaging/protobuf.checksums \
@@ -981,6 +983,7 @@ NETDATA_COMMON_LIBS = \
libjudy.a \
$(OPTIONAL_SSL_LIBS) \
$(OPTIONAL_JSONC_LIBS) \
+ $(OPTIONAL_YAML_LIBS) \
$(OPTIONAL_ATOMIC_LIBS) \
$(OPTIONAL_DL_LIBS) \
$(NULL)
@@ -993,6 +996,10 @@ if LINK_STATIC_JSONC
NETDATA_COMMON_LIBS += $(abs_top_srcdir)/externaldeps/jsonc/libjson-c.a
endif
+if LINK_STATIC_YAML
+ NETDATA_COMMON_LIBS += $(abs_top_srcdir)/externaldeps/libyaml/libyaml.a
+endif
+
NETDATACLI_FILES = \
daemon/commands.h \
$(LIBNETDATA_FILES) \