summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorthiagoftsm <49162938+thiagoftsm@users.noreply.github.com>2019-06-27 08:16:28 -0300
committerPaul Emm. Katsoulakis <34388743+paulkatsoulakis@users.noreply.github.com>2019-06-27 13:16:28 +0200
commit60a73e90de2aa1c2eaae2ebbc45dd1fb96034df2 (patch)
tree3729a7e43a2a9e6395fc85f2a2cd74b833e414a8 /Makefile.am
parent6fc971fe4d070d7c3e666ee24fb0c43d43084c85 (diff)
Easily disable alarms, by persisting the silencers configuration (#6274)
* Alarms begin! * Alarms web interface comments! * Alarms web interface comments 2! * Alarms bringing Christopher work! * Alarms bringing Christopher work! * Alarms commenting code that will be rewritten! * Alarms json-c begin! * Alarms json-c end! * Alarms missed script! * Alarms fix json-c parser and change script to test LIST! * Alarms fix test script! * Alarms documentation! * Alarms script step 1! * Alarms fix script! * Alarms fix testing script and code! * Alarms missing arguments to pkg_check_modules * SSL_backend indentation! * Alarms, description in Makefile * Alarms missing extern! * Alarms compilation! * Alarms libnetdata/health! * Alarms fill library! * Alarms fill CMakeList! * Alarm fix version! * Alarm remove readme! * Alarm fix readme version!
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am12
1 files changed, 9 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 6dacd825ef..2729af38ad 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -159,8 +159,14 @@ LIBNETDATA_FILES = \
libnetdata/storage_number/storage_number.h \
libnetdata/threads/threads.c \
libnetdata/threads/threads.h \
- libnetdata/url/url.c \
- libnetdata/url/url.h \
+ libnetdata/url/url.c \
+ libnetdata/url/url.h \
+ libnetdata/json/jsmn.h \
+ libnetdata/json/jsmn.c \
+ libnetdata/json/json.h \
+ libnetdata/json/json.c \
+ libnetdata/health/health.c \
+ libnetdata/health/health.h \
$(NULL)
APPS_PLUGIN_FILES = \
@@ -506,12 +512,12 @@ endif
NETDATA_COMMON_LIBS = \
$(OPTIONAL_MATH_LIBS) \
$(OPTIONAL_ZLIB_LIBS) \
- $(OPTIONAL_SSL_LIBS) \
$(OPTIONAL_UUID_LIBS) \
$(OPTIONAL_UV_LIBS) \
$(OPTIONAL_LZ4_LIBS) \
$(OPTIONAL_JUDY_LIBS) \
$(OPTIONAL_SSL_LIBS) \
+ $(OPTIONAL_JSONC_LIBS) \
$(NULL)
sbin_PROGRAMS += netdata