summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorvkalintiris <vasilis@netdata.cloud>2021-12-07 15:13:21 +0200
committerGitHub <noreply@github.com>2021-12-07 15:13:21 +0200
commit1fd40e59d84ad6cad8d33cb0cbe7f8b890f2e465 (patch)
treea6dfba89259f21ef430b378965f8cf5963a6d6db /Makefile.am
parent35a8e54020c15458bd2e60672e66ec1f51618a89 (diff)
Detect whether libatomic should be linked in when using CXX linker. (#11818)
* Detect whether libatomic should be linked in when using CXX linker. There was already a check for this when building with the bundled protobuf. Considering that we needed the same check when building for ML, I moved the check so that it can happen in either case when a C++ linker is required for the build to succeed. * Try to unconditionally link with -latomic, if the library is available.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 61213ca8d9..5b1c7a31af 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -969,6 +969,7 @@ NETDATA_COMMON_LIBS = \
$(OPTIONAL_JUDY_LIBS) \
$(OPTIONAL_SSL_LIBS) \
$(OPTIONAL_JSONC_LIBS) \
+ $(OPTIONAL_ATOMIC_LIBS) \
$(NULL)
if LINK_STATIC_JSONC
@@ -995,7 +996,6 @@ netdata_LDADD = \
if ACLK_NG
netdata_LDADD += $(OPTIONAL_PROTOBUF_LIBS) \
- $(OPTIONAL_ATOMIC_LIBS) \
$(NULL)
endif