summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorVladimir Kobal <vlad@prokk.net>2019-05-13 15:45:34 +0300
committerChris Akritidis <43294513+cakrit@users.noreply.github.com>2019-05-13 14:45:34 +0200
commit198c7fa3e34c71bc075bcfb067da80242e74bddf (patch)
tree906a580bf1658a09f67836dbff5f93cced079382 /Makefile.am
parent51decad9896131ed478681d90886d63bbd953b14 (diff)
Add AWS Kinesis backend (#5914)
* Add Kinesis backend * Separate config file * Send data in chunks * Fix minor issues * Add error handling * Use existing JSON functions * Do not retry on send failure * Implement building with autotools * Implement building with CMake * Fix CMake variables * Fix build when C++ compiler is not available * Add checks for C++11 * Don't reinitialize API * Don't reinitialize client * Minor cleanup * Fix Codacy warning * Separate sending records and receiving results * Add documentation * Make connection timeout configurable * Fix operation metrics * Fix typo * Change parameter names for credentials * Allow using the default SDK credentials configuration
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am19
1 files changed, 18 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index ee5ba9f172..7f3604ef83 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -412,6 +412,13 @@ BACKENDS_PLUGIN_FILES = \
backends/prometheus/backend_prometheus.h \
$(NULL)
+KINESIS_BACKEND_FILES = \
+ backends/aws_kinesis/aws_kinesis.c \
+ backends/aws_kinesis/aws_kinesis.h \
+ backends/aws_kinesis/aws_kinesis_put_record.cc \
+ backends/aws_kinesis/aws_kinesis_put_record.h \
+ $(NULL)
+
DAEMON_FILES = \
daemon/common.c \
daemon/common.h \
@@ -471,13 +478,18 @@ NETDATA_COMMON_LIBS = \
$(OPTIONAL_ZLIB_LIBS) \
$(OPTIONAL_UUID_LIBS) \
$(NULL)
-
+# TODO: Find more graceful way to add libs for AWS Kinesis
sbin_PROGRAMS += netdata
netdata_SOURCES = $(NETDATA_FILES)
netdata_LDADD = \
$(NETDATA_COMMON_LIBS) \
$(NULL)
+if ENABLE_BACKEND_KINESIS
+ netdata_LINK = $(CXXLD) $(CXXFLAGS) -o $@
+else
+ netdata_LINK = $(CCLD) $(CFLAGS) -o $@
+endif
if ENABLE_PLUGIN_APPS
plugins_PROGRAMS += apps.plugin
@@ -531,3 +543,8 @@ if ENABLE_PLUGIN_XENSTAT
$(OPTIONAL_XENSTAT_LIBS) \
$(NULL)
endif
+
+if ENABLE_BACKEND_KINESIS
+ netdata_SOURCES += $(KINESIS_BACKEND_FILES)
+ netdata_LDADD += $(OPTIONAL_KINESIS_LIBS)
+endif